Error adding regression test: No such file: item


#1

I’m trying to add a regression test to the Grammar Matrix. I’m getting an error message that complains that there isn’t already an item file. I’m in my branch and using -C gmcs/ to set the CUSTOMIZATIONROOT… Does anyone know what this is indicative of?

kphowell@kphowell-VirtualBox:~/delphin/computel_2019_ctn$ python matrix.py -C gmcs/ ra oracle test
Enter a short comment describing this regression test: oracle choices file on test data
FAIL!
Traceback (most recent call last):
File “matrix.py”, line 992, in
main()
File “matrix.py”, line 193, in main
txtsuite)
File “/home/kphowell/delphin/computel_2019_ctn/gmcs/regression_tests/add_regression_test.py”, line 106, in add
shutil.copy(os.path.join(rt_root, “home”, “gold”, lg_name, “item”), os.path.join(rt_root, “skeletons”, lg_name))
File “/usr/lib/python2.7/shutil.py”, line 119, in copy
copyfile(src, dst)
File “/usr/lib/python2.7/shutil.py”, line 82, in copyfile
with open(src, ‘rb’) as fsrc:
IOError: [Errno 2] No such file or directory: ‘/home/kphowell/delphin/computel_2019_ctn/gmcs/regression_tests/home/gold/ctn-oracle-test/item’


#2

I don’t remember if I saw this error in particular, but sometimes an incorrect ACEROOT setting is to blame?..


#3

Hm. I don’t think it’s that. I have it set in my .bashrc and I tried doing an export ACEROOT= as well. I still get the same error.


#4

And you’ve set everything up as in here? http://moin.delph-in.net/MatrixRegressionTestingSetup (Just checking). In other words, that’s the same VM that you’ve been using for regression testing before? (I realize it probably is, but just to rule all the obvious stuff out).

The /home/kphowell/delphin/computel_2019_ctn/gmcs/regression_tests/home/gold/ctn-oracle-test/item is actually there?


#5

The info here might also be informative:

http://moin.delph-in.net/MatrixRegressionTesting

Specifically the part on adding regression tests.


#6

It’s good to check the obvious stuff. It’s the same VM as before and I checked that page and everything still looks like it’s there. The only difference is that I’m using a new branch (created the morning). The only branch specific thing on that page that I can see is getting the iso.tab file (the command there doesn’t seem to work-- I get a not found error, but there is a copy of it in svn anyway).
I’m trying it in my old branch, and it’s just spinning-- I’ll give that a little more time while I read through the documentation for a clue.


#7

Oh yeah, I remember the iso.tab being important for some reason!

And is non-ctn stuff still working in your old branch, like if you try to add a copy of some clausal mods test? (I mean, just grab a choices and a test suite from an existing test and add them as another test).


#8

It turns out it was unexpected arguments in the choices file. After section and language, it had iso-code, archive, email, affiliation, motivation, vcs. I’m not sure which was problematic (I remember there being a bug with iso-code, but I thought that had been fixed), but I removed all of them and it worked.