Fftb binary for OSX?

I’m trying to get set up with fftb — in order to help the folks currently working on AGG-related things to use treebanking. As of Feb '21 there was no compiled version for OSX:

I’m assuming that’s still true but thought I’d ask here (especially because I remember using fftb on OSX in 2019-2020…)

Here’s an FFTB binary for OSX that works on my 10.15 Mac. YMMV?

http://sweaglesw.org/linguistics/fftb-osx-2022.tar.gz

1 Like

Thank you! I hope to get a chance to try it soon.

Hi @sweaglesw, may I add all binaries for FFTB in a proper Release at GitHub - delph-in/fftb: Full-forest Treebanker? This is also related to an idea that @goodmami and I have started to discuss about having a GitHub repo for all other ACE-related tools.

BTW, I tried and it is working on Mac OS 12.3.1 (2,6 GHz 6-Core Intel Core i7)

Hi @sweaglesw in the page FftbTop · delph-in/docs Wiki · GitHub we have a link to http://sweaglesw.org/linguistics/osx-fftb.tar.gz but above you provide another link http://sweaglesw.org/linguistics/fftb-osx-2022.tar.gz, should we take this second one as the official binary of FFTB for MacOS, right?

It looks like the one linked in the wiki was compiled with dynamic libs and this second one was compiled with static libs, right?

ar@tenis fftb-osx-2022 % ./fftb
usage:  ./fftb -g grammar.dat [--gold profile_path [--auto]] [--browser [firefox]] [--webdir web_path] [--port port_number] profile_path

ar@tenis osx-fftb % ./fftb
dyld[38785]: Library not loaded: liba.dylib
  Referenced from: /Users/ar/Downloads/osx-fftb/fftb
  Reason: tried: 'liba.dylib' (no such file), '/usr/local/lib/liba.dylib' (no such file), '/usr/lib/liba.dylib' (no such file), '/Users/ar/Downloads/osx-fftb/liba.dylib' (no such file), '/usr/local/lib/liba.dylib' (no such file), '/usr/lib/liba.dylib' (no such file)
zsh: abort      ./fftb

The 2022 one is just more up to date. I don’t think the program has changed much. The OSX versions supported may be different.

Feel free to copy it in whatever redistribution you like. It would be best if there is a record of what came from where.

Do you know how to handle that dylib error, @arademaker? (I’m hitting it too, but I don’t know what to try to get around it.)

Thanks!

Hi @ebender , I am using the http://sweaglesw.org/linguistics/fftb-osx-2022.tar.gz version provided by @sweaglesw, this was compiled with static-libs so it does not need to locate the .dylib files at runtime. I will make a release in Releases · delph-in/fftb · GitHub with that version.

I’m interested in using the OSX version too but haven’t been able to get it to work yet. Here’s the issue I’m running into:

The 2022 version doesn’t bring up the dylib error, like @arademaker mentioned, but it seems to be using ace-0.9.34, so I get a version mismatch error saying that it’s incompatible with my grammar image (which was compiled using ace-0.9.30). Trying to run ace-0.9.34 gets me an exec format error (I’m wondering if this is because there isn’t an acetools-0.9.34?).