FFTB profile: getting 0 parses but the edge file is non-empty

Hi,

I am trying to treebank a language but no parses are shown in the fftb for all test items (i.e. the result file in the fftb profile is empty). However, the edge file in the profile is non-empty so there’s supposed to be parses for (some of) the items.

I also checked whether the test items are able to be parsed using [incr tsdb()], and some of the items do get parses.

Does anyone have insights on what might be causing this?

How did you create the profile to treebank?

The way I created the profile for treebanking was (I was referring to the fftb instruction):

  1. Creating a tsdb profile for the grammar downloaded from the matrix customization system web page and the test items
  2. Generating a .dat file with ace by running: ace-0.9.30/ace -G {grammar_dir}/ace/{grammar}.dat -g {grammar_dir}/ace/config.tdl
  3. Creating a fresh profile in full forest mode with: art-0.1.9/mkprof -s {original_profile} {new_profile}
  4. Processing the freshly created fftb profile with: art-0.1.9/art -f -a '{full_path_to_ace}/ace-0.9.30/ace --disable-generalization -g {grammar_dir}/ace/{grammar}.dat -O' {new_profile}

This procedure will indeed create a parsed profile where the edge' relation is non-empty, but where the result’ relation is empty. This is because in step 4, the option “-0” is given after the .dat file name, and this tells the art process to compute the packed parse forest and store it in the edge' relation, but to then compute 0 results. This is fine if you then expect to treebank that profile in order to select the desired parse for each item. When you do this, the treebanking tool will store the chosen parse for each item in the result’ relation. If you already have a parse-selection model, and just want to compute and store the one highest-ranked parse for each item in the `result’ relation, then change the parameter in that step 4 from -0 to -1.

@arademaker @Dan Thank you for helping!