Fw_seq doesn't offer parse with `quoted` predications for "where is '/'"

The 2020 ERG produces 4 parses for:

Where is “/”?

But none of them include a quoted predication (from pydelphin output):

<MRS object (loc_nonsp place_n which_q proper_q fw_seq _and_c) at 140478016047696>
<MRS object (loc_nonsp place_n which_q proper_q fw_seq _/_a_1) at 140478016780656>
<MRS object (loc_nonsp place_n which_q proper_q fw_seq _per_p udef_q) at 140478016780544>
<MRS object (loc_nonsp place_n which_q proper_q fw_seq _per_p) at 140478016780432>

Is this a bug or is there something else at work here?

This phrase is a simpler (in terms of parses) version of “go to ‘/’” (which has the same problem) that I’m trying to interpret in a documentation sample for an English interface to a file system.

Another example:

copy “/Desktop/blue” in “/documents”

Generates 732 Parses in ERG 2020, but the only quoted predication that appears in them is this one:

[ quoted<25:35> LBL: h24 ARG0: i25 CARG: "/documents" ]

And they only get a fw_seq predication that references that predication as well. The ERG doesn’t seem to be recognizing “/Desktop/blue” as a fw_seq

One more piece of data here: changing all / to \ in all the text I’ve tried (including the above examples) generates the alternatives I’d expect, except for “\” (single backslash in quotes) which still doesn’t get quoted.

You are right that the treatment of the slash character in 2020 does not accommodate its participation in “foreign-word” sequences. The bug is now fixed in the upcoming 2023 release of the ERG.

1 Like