GLIB_C.28 error

Dear all,
I’m having trouble installing lkb_fos on Ubuntu. First of all, I made sure I have an 86 bit set up:

$ uname -a
Linux 5.4.0-91-generic #102~18.04.1-Ubuntu SMP Thu Nov 11 14:46:36 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux

Then, I followed the instructions (created the delphin and tmp directories, set up the path with “export”, added it to my ~/.bashrc file, installed xclip) and typed:

$ ~/delphin/lkb_fos/./lkb.linux_x86_64

That returned the error:

./lkb.linux_x86_64: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.28' not found (required by ./lkb.linux_x86_64)`

I’m really weary of tinkering with GLIBC_2.28, and risking messing up my linux installation.

Thank you in advance, for any tips. I’m sure this is aggressively trivial to solve…
R

@RuiChaves It seems that Ubuntu 18.04 comes with glibc 2.27; I created the lkb_fos Linux binary on Ubuntu 19.04 with glibc 2.31. I’ve had a think about possible solutions:

  1. You could upgrade to 19.04. However, I assume this would not be attractive.

  2. I could build a statically linked binary. In principle this is possible, but the procedure is pretty painful.

  3. I could find a Linux distribution <= 18.04 and build a new binary. This might work OK on your 18.04.

I decided to try this last option. Fortunately, I have an old VM image based on Ubuntu 14.04, so I’ve built a new binary in that; it seems to run fine in my 19.04 so I’m hopeful it will also work for you.

Please download the binary from http://users.sussex.ac.uk/~johnca/lkb.linux_x86_64.GLIBC_2.19 [35.8 MB], put it in your lkb_fos directory and try running it. Does it work OK? If so, I’ll consider building all future releases this way, so as to work on old systems while also hopefully being forward-compatible to the latest.

1 Like

Dear John,
Thank you so much for this. It is working fine!
R

May I suggest one additional option? @RuiChaves can work in an isolated environment. GitHub - LR-POR/delphin-docker: A docker container for running all DELPH-IN tools in a Linux box. can be a good solution for that kind of situation.

1 Like

Dear Rui,

I’m glad the new binary works for you.

There’s some discussion about the LD_LIBRARY_PATH warning message at https://delphinqa.ling.washington.edu/t/incr-tsdb-podium-doesnt-list-profiles-lkb-fos/701 . [incr tsdb()] needs to pick up a couple of .so files in order to work correctly, including bdb.so and libtermcap.so.2 . If you’re not using [incr tsdb()] then you can ignore this message.

Hope this helps,

John

Yes, I later set up the path variable and the warning went away. I didn’t think to do that because I didn’t install [incr tsdb()], as you pointed out.

All is running perfectly.
Many thanks!