"Hit RAM limit while unpacking" when using -p flag in ACE

I am running ACE as follows, using pydelphin:

delphin process --options="-p -1 -y --yy-rules --max-chart-megabytes=48000 --timeout=1800" -g ~/delphin/GAUSS/gauss-repo/grammars/srg-mal/ace/srg-mal.dat --full-forest --select i-tokens "$profile"

As you see, I am using the -p flag to turn off packing. Yet I am seeing the following notes when parsing:

NOTE: hit RAM limit while unpacking

Is this unpacking something else, not related to the -p flag?

There is still an “unpacking” phase with -p; it’s just mostly a no-op. You probably need to increase the max unpacking megabytes limit to be a bit over the chart limit.

1 Like