LKB-FOS + [incr tsdb()]?

We’re trying to set up this year’s iteration of the Ubuntu+LKB virtualbox disk imagine with LKB-FOS. @johnca – what is the expected interaction between LKB-FOS and [incr tsdb()]?

Not expecting any replies over the holidays!

@ebender The Linux LKB-FOS binary contains [incr tsdb()] but it doesn’t open the podium on startup. Execute (tsdb:tsdb :podium) to open it – either by typing this at the command prompt or by selecting it from Evaluate lisp expression… in the LKB Top Advanced menu. I could change this behaviour if it’s inconvenient.

There’s one obscure but unfortunate bug in LKB-FOS that I’d like to fix before it gets baked into Ubuntu+LKB. If I make a new release next week, would you be able to pick that up instead of the current one?


Thanks @johnca! I think @bmgraves will be making a new image next week, so we may be able to catch the fix. Please keep up posted!

As for [incr tsdb()], trying the command gets me this:

  • (tsdb:tsdb :podium)
    /bin/sh: 1: exec: /home/ubuntu/delphin/lkb_fos/bin/linux.x86.64/swish++: not found

But swish++ is definitely at that path, so it sounds like we’re missing some config piece around paths…

@ebender @bmgraves The swish++ problem could be due to the fact that in the current (July 11) release of LKB-FOS, I inadvertently included a 32-bit version of swish++. This requires /lib/ to run, which might be missing. The upcoming release will include a 64-bit swish++, which requires /lib64/

Is this the problem?


Ah, it could well be! @bmgraves is off for the long weekend, but I expect he’ll be around to look into it come Monday.

@bmgraves I’ve made a new release of LKB-FOS - please include it in the Ubuntu+LKB image if at all possible. It’s at the usual place:

Many thanks, @johnca!

Much thanks! I will get this downloaded and update the ubuntu image!

1 Like

Very puzzlingly, a student who is using the same VB appliance as I am are hitting this error on trying to run (tsdb:tsdb :podium)

/home/ubuntu/delphin/lkb_fos/bin/linux.x86.64/tsdb: error while loading shared libraries: cannot open shared object file: No such file or directory

He checked /home/ubuntu/delphin/ and confirmed that is there.

@johnca and @bmgraves do you have any ideas why it might be working for me and not them?


@ebender @bmgraves My first two guesses would be that somehow the student has:

  • lost from the directory /home/ubuntu/delphin/lkb_fos/lib/linux.x86.64/ or
  • got an incorrect setting for the environment variable LD_LIBRARY_PATH

Perhaps the student has customised their ~/.bash_profile or ~/.profile file incorrectly?

Thanks! I will ask them to check those two things.

Still not quite sure what’s going on, but we managed to fix it for these students by doing:

ubuntu@lkb:~$ . .bash_profile

and then being careful to invoke emacs from the command line rather than clicking on the emacs icon.

What’s mysterious is how the LD_LIBRARY_PATH is ended up empty (it was) for some of us and not others, using the same VB image.

Hi John, the SVN is updated? Is it in sync with this last release? My local svn up shows Updated to revision 29197.

@arademaker It’s SVN revision 29196 that corresponds to this latest binary release. However there seem to be no differences between 29197 and 29196.

1 Like

There is also the Docker alternative:

This solution can potentially demand less resources than a complete VM machine. The image current contains Ace (and related tools) and it was created to use the files/programs from the LOGON directory cloned in the host machine… I would be happy to adapt the docker image to any other specific demands, maybe it is time to reduce the dependency on the LOGON directory structure.

1 Like