LUI won't initialize


#1

I updated my Ubuntu VM (bad idea) and now LUI crashes regularly for me. I checked the wiki at http://moin.delph-in.net/LkbLui#Trouble_Shooting which gave some suggestions for 10.04 (I am running 16.04), but they didn’t work. I could swear I’ve had this problem, but I don’t remember how to solve it.

Here is the error I get when I run (lui-initialize):

LKB(4): (lui-initialize)
[NIL] lsp-loop(): premature end of file (read 1 characters)
#<MULTIPROCESSING:PROCESS LUI(4) @ #x5b549522>

I am running the logon distribution, and even did a fresh install. Does anyone know/recall how to fix this?


#2

Sorry I don’t know the answer for this particular error message, but in general for a fresh install I only need to install libpng12 and maybe libjpeg 6 (or symlink /lib/libjpeg.so.62 to a recent version; see http://moin.delph-in.net/LogonArch). For Ubuntu also see http://moin.delph-in.net/LogonUbuntu and maybe http://moin.delph-in.net/LogonDebian. All of the above-linked instructions are years old, though, but since you’re using a 3-year-old version of Ubuntu they might be applicable.


#3

I was missing some of the libraries, the sudo apt-get commands solved it.