Setting up LTDB: not seeing different databases in the browser

I ran the script (after downgrading flask to 1.4.1, since otherwise the script reported incompatibilities), and also ran the grm2db python script and created a database. In the video from the summit discussion, @bond is able to click on the name of the grammar to get to a list of databases, and then chooses one. The ERG is the one he originally has open.

I am not sure how to get to that point, or maybe I did the installation incorrectly. I note the local server address in the terminal where I ran the script, and when I enter that address in the Firefox browser, I do see the ERG mentioned when I type in the address but then what I see is in fact the OMW?

Anyone knows what I did wrong?

My situation:

Summit video:

I remember there was a bit where Francis had to go find something that landed in the tmp directory…

Yep, I did that bit. That is needed for the new database to appear in the web/db directory. That’s where I have all the databases.

I can edit a line in web/ to make a variable “grm” point to SRG specifically, and that works. But would still be good to know what Francis’s setup was in the video!

Have you also replied to this one by email @bond ? If so, could you please repeat it through the browser?

I believe this was due to outdated files in the LTDB repo (which is now fixed).